Animated Battlers Update

Hi everyone Archeia here!

Unfortunately, I am unable to edit the page for Animated Battlers because of limited permissions. I just hope that people won’t miss this post. Here’s Animated Battlers Version 1.09, for a list of updates, here’s what we have:

  • Anti-Lag implemented. Depending on how intensive animations can be for enemies, the game could lag.
  • Enemies attacking too fast, now they have been slowed down a bit to be in time with damage popups.
  • After a pose’s animation, change to a specific animation. E.g. After hitting a skill, make them go back to idle pose immediately. This can be achieved by adding ToAnimationID (e.g. To111) on the animation’s name in the database editor.
  • Show a Damage Pop-up on a specific frame #  by adding <damage at: n> at the skill notetag.
  • Jump to target tag by adding <jump to target> at the skill notetag.

I…think that’s mostly it. It’s been a while since we implemented this fixes so I don’t remember how some of the functions work aside from a few notes here and there, Kread hasn’t been around so there won’t be any fixes, probably, but feel free to report some! Just make sure to follow this format:

  • Description of the bug. Make sure to note HOW it happens and try to emulate it as much as possible.
  • List of scripts used. This is important! If you use Victor’s scripts, then it’s a given the scripts won’t work due to low compatibility.
  • Did you test it in a fresh new project? If no, then try at a new project first.
  • Did you load a save and encountered the bug there? If yes, then start a new game and see if the problem persists.
  • Did you check Yanfly’s Core first for bug fixes list? Is the bug mentioned there? If yes, then grab that script.
  • Did you read the features of the script first before assuming it’s not working like what you thought it would? If no, then read.
  • Did you try putting the script above/below other/certain scripts first? Give it a try, it might just fix it.
  • Give us a demo if possible. No need for the entire game, but just the area where it bugs out.

Hopefully this will make the bug fixing easier for everyone.

Advertisements

Posted on 03/06/2014, in RGSS3 and tagged , . Bookmark the permalink. 10 Comments.

  1. First of all, your script is AWESOME; well i have two “little” problems; the first one is with the tag: its not working, the damage pop-ups ignore the tag, and displayed until the end of the animation. The second “problem” is the actor positions: Is there a way to change the actors position during the game, “depending of the battleback”?.

    This is my script list: “Basic damage pop-up by Vlue” and almost all Moghunter battle addons scripts, except the damage pop up and the related animations scripts.

  2. I wanted to leave a note regarding the custom traits feature not displaying custom traits correctly

    Full details at http://www.rpgmakervxace.net/topic/22556-traits-namer-kread-ex-custom-traits-not-displaying/

    • i found out how to fix this
      final_value = case code
      when 11, 13
      100 – (value * 100)
      when 33, 34
      value
      else
      value * 100
      end
      you have to counter the math done to value so with the poison thing with 100%, you change the value from ‘100’ to ‘100/100’ this will fix the problem. i am having touble fixing the problem where the % for potions and things arent showing properly… its always 0%

  3. Just a quick question from a first time user on setting up the animation sheets – is there a ‘proper’ placement of battlers in each animation tile/cell? I think I saw Kread mention elsewhere to somebody else their cells were off-center so I thought it best to ask just in case.

  4. Hi, I was playing around with the script and was hoping someone would be able to help me with what is likely something very minor. I set it so a certain state had an animation, yet the animation only plays sometimes. On my turn, the character will default to their idle stance. Is there something I have to set in order to make them stay on the state’s animation?

  5. Nonemployee

    Not sure where to put a bug report but maybe someone else can help me. So sorry, but this will be a long comment.

    To start off, I looked at and/or tried every animated battler script, but this is the only one I can get working. (maybe because I used battle animations back in rm2k3?) BUT I’m still having a problem.

    Description: When animated party member takes damage, whether alone or with other party members, they freeze on their damage frame.

    List of scripts: In order- Yanfly Core, Victor Basic Module, Victor Engine Step Sound, Yanfly Battle Engine, Yanfly Victory Aftermath, Yami Charge Skill, Kread-EX Animated Battlers

    Loaded save? – No

    Try moving script: Yes

    I have also searched any kind of way on google for help, but if I find someone with similar problems, they either never get a reply or fixed it themselves without explaining how. I’ve tried putting No_Loop, Wait, and ToXXX (though not sure if that last one works) in the same one, first two, first and last, and such. I also tried removing scripts, removing all but the animated battle script, and more but to no avail.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: